设置Weex Toolkit引出的node.js完全卸载方法小记

在mac终端通过命令安装mysql,安装命令,快速搭建以太坊私链,区块链学习一 MAC上以太坊私有链搭建,需要先pod setup,      CocoaPods会将这些podspec索引文件更新到本地的,才会让weex-toolkit无法成功安装,安装Weex Toolkit方法很简单

     消除措施:sudo chown -汉兰达$(whoami) /usr/local,

陆. macbook 启用tab自动补全

要布局tab自动补全功能,得须求用root用户权限,那么就先运维root权限.

张开终端之后,以后暗中同意进去的是你登入的用户,今后要切换到root用户:

壹、su root,然后输入密码成功登6

2、输入 nano .inputrc

3、再输入以下语句:

set completion-ignore-case on

set show-all-if-ambiguous on

四、输入完成后,按 Control +
o.关闭当前终端,重新展开三个新的终端,tab补全不区分轻重缓急写,成功。

miner.stop()之后回车,就可以甘休挖矿。停不住。。。

INFO [07-07|19:00:21.438] Generating DAG in progress epoch=1
percentage=29 elapsed=26.360sINFO [07-07|19:00:22.325] Generating
DAG in progress epoch=1 percentage=30 elapsed=27.247s

MAC 发烫啊。

更新:

上边是一点一滴卸载node的艺术

举例是由此brew安装的,则一贯利用
brew uninstall node

若不是还是曾经因而brew卸载了,则(删除从前,确认一下文件是还是不是存在,并且是不是为理应删除的文书)

  • 删去/usr/local/lib中的全数node和node_modules
  • 剔除/usr/local/lib中的全数node和node_modules的公文夹
  • 检查~/中全数的local, lib大概include文件夹,
    删除里面装有node和node_modules
  • 在/usr/local/bin中, 删除全数node的可施行文件
  • sudo rm /usr/local/bin/npm
  • sudo rm /usr/local/share/man/man1/node.1
  • sudo rm /usr/local/lib/dtrace/node.d
  • sudo rm -rf ~/.npm
  • sudo rm -rf ~/.node-gyp
  • sudo rm /opt/local/bin/node
  • sudo rm /opt/local/include/node
  • sudo rm -rf /opt/local/lib/node_modules
  • /usr/local/include/node
    等等。。。

下一场经过
$ node
$ npm
检查一下,是或不是把施用卸载好了,ok了就能够重新安装

重新利用brew安装node时,产生了2个更奇葩的事,brew坏了,只能重新安装brew,命令如下
/usr/bin/ruby -e “$(curl -fsSL
https://raw.githubusercontent.com/Homebrew/install/master/install)”

使用
brew install node
就能够安装

设置途中,有希望提醒,某某文件被攻陷,这时,能够把某某文件删掉(那是此前node卸载遗留的文书)
与此同时,恐怕提示,已经安装好了,可是从未link而已,那时能够看来link方法的唤醒
brew link node
只是,link时有望说某某文件并未有权力(小编当即出现的是说tapset),sudo在brew上也是不可动用的了,那时供给
$ cd /usr/local/share/systemtap
$ chown -R tapset
再进行link就ok了

接下去,安装weex-toolkit就很顺畅了


再接下去,还没完,gem和pod全挂了。。。

漏洞非常多提醒如下
dyld: Library not loaded: /usr/local/lib/libgmp.10.dylib
Referenced from: /Users/derek/.rvm/rubies/ruby-2.2.1/bin/ruby
Reason: image not found

则谷歌之,开采能够透过重复安装ruby来消除,最初的小说中的方法如下:

$ ruby -v
dyld: Library not loaded: /usr/local/lib/libgmp.10.dylib
Referenced from: /Users/psoshnin/.rvm/rubies/ruby-2.1.3/bin/ruby
Reason: image not found

$ brew update && brew upgrade
$ rvm reinstall 2.1.3 –disable-binary # 贰.一.叁是ruby版本,见ruby
-v的谬误提醒,各样人的或然两样,举个例子自个儿是2.2.一

$ ruby -v
ruby 2.1.3p242 (2014-09-19 revision 47630) [x86_64-darwin13.0]

品味第二遍,在install的时候,会冒出
Error running ‘__rvm_rm_rf /Users/derek/.rvm/rubies/ruby-2.2.1’,
showing last 15 lines of
/Users/derek/.rvm/log/1492230416_ruby-2.2.1/remove.rubies.log

再一次开始展览 brew update 后就像常了
从那之后,gem寻常了,重新安装pod就可以


brew:
https://brew.sh/index\_zh-cn.html
金沙国际唯一官网网址,chown:
http://www.cnblogs.com/peida/archive/2012/12/04/2800684.html

  Check you have permission to write to /usr/local

三. chown: /usr/local: Operation not permitted难题解决

在MAC上设置homebrew,遵照步骤实行下去,在brew
update的时候出现报错:Error: /usr/local must be writable! 错误.

解决办法(sudo chown -CR-V $ /usr/local) 对
高版本的OS来讲,是解决不了的,会报 chown: /usr/local: Operation not
permitted错误。

先卸载已安装的homebrew,命令如下:

/usr/bin/ruby -e “$(curl -fsSL
)”

然后重新安装:

/usr/bin/ruby -e “$(curl -fsSL
)”

经过该措施直接获取最新的homebrew。

1、安装顺序:Homebrew->rvm->ruby->cocoapods

但是,提醒了奇葩的荒唐,谷歌(Google)之不可解,遂只好干掉node,重新安装node
后来在探求方法的历程中窥见,可能是Mac系统晋级导致了node的主题材料,才会让weex-toolkit不可能成功安装
孰是孰非,暂不可定论

  然后重新安装:

4. mac 执行brew update 报错 Error: Could not link: /usr/local/etc/bash_completion.d/brew

Error: Could not link:/usr/local/share/doc/homebrew

Please delete these paths and run brew update.

消除办法

rm -rf /usr/local/share/doc/homebrewbrew update

     
 You can try adding it manually in `~/.cocoapods/repos` or via `pod repo add`.

设置Weex Toolkit方法极粗略,如下命令:
$ npm install -g weex-toolkit

(2)提醒错误:

以太坊支出极简入门

            rvm install 2.3.1

     消除方式:先卸载已设置的homebrew,命令如下:

5. brew install xxx卡在Updating Homebrew

化解措施,关闭自动更新

export HOMEBREW_NO_AUTO_UPDATE=true

       1、pod repo add master

   Error: Git must be installed and in your PATH!

总体的MAC搭建私链,参考如下叁篇博客就可以,再一次不再赘言。

2、查看cocoapods:pod –version

 

高速搭建以太坊私链


  消除办法:xcode-select –install

这里写的片段坑的地点,MAC系统下。

            ruby -e “$(curl -fsSL
)”

 

贰. Brew安装难题

设置 Homebrew
非常粗略,不过速度太慢了,作者壹再试了5回,fq、手提式有线电话机火爆等等,才成功。

安装 Homebrew 官网

二、安装cocoapods,报错:activesupport requires Ruby version >=
2.2.2,如下图:

(1)设置命令:brew install mysql

1. Mac下打开/usr/local目录

Mac下/usr/local目录私下认可是对于Finder是逃匿,倘使急需到/usr/local下去,张开Finder,然后利用command+shift+G,在弹出的目录中填入/usr/local就能够了。